Difference between revisions of "System requirements"

From SUMOwiki
(Compilation Requirements)
(Mandatory Requirements)
Line 1: Line 1:
 
== Mandatory Requirements ==
 
== Mandatory Requirements ==
   
In order to use the SUMO toolbox you must have at least the following:
+
In order to use the SUMO Toolbox you must have at least the following:
   
 
* [http://www.mathworks.com/ Matlab] version 7.2, 7.3, or 7.4. Previous versions ''may'' work if you are lucky, it depends on what you need. The same goes for later versions.
 
* [http://www.mathworks.com/ Matlab] version 7.2, 7.3, or 7.4. Previous versions ''may'' work if you are lucky, it depends on what you need. The same goes for later versions.

Revision as of 03:17, 6 February 2008

Mandatory Requirements

In order to use the SUMO Toolbox you must have at least the following:

  • Matlab version 7.2, 7.3, or 7.4. Previous versions may work if you are lucky, it depends on what you need. The same goes for later versions.

In addition the following Matlab toolboxes are strongly recommended

  • Neural Network Toolbox
  • Genetic Algorithm and Direct Search Toolbox
  • Optimization Toolbox

The SUMO-Toolbox will work on every operating system that Matlab supports (Windows, Mac OSX, Linux, Solaris, ...), see the Matlab website for details.

Compilation Requirements

If you want to compile the toolbox from source you will need:

  • Java SDK v1.5 or greater (we have only tested the JDK from Sun Microsystems)
  • Apache Ant or Eclipse

If you want to use some of the Support Vector Machine or fast Neural Network libraries you will need the standard GNU tools (make, gcc, ...) as well.

See the installation instructions for how to compile the toolbox.